User Tools

Site Tools


proxmox_notes

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revisionPrevious revision
Next revision
Previous revision
proxmox_notes [2025/07/22 12:58] – mikeproxmox_notes [2026/08/12 04:15] (current) – mike
Line 1: Line 1:
 ====== ProxMox Notes ====== ====== ProxMox Notes ======
 +
 +===== Post-Install Tasks =====
 +==== Disable/remove the annoying "no subscription" message that pops during login ====
 +Visit https://free-pmx.pages.dev/tools/free-pmx-no-subscription/ and install the package located there.
 +
 +==== Set up notification emails ====
 +Datacenter > Notifications
 +
 +==== Set up remote syslogging ====
 +  apt update && apt -y install rsyslog
 +Once installed, edit /etc/rsyslog.conf and add the following section to the bottom; provide the proper IP address where noted:
 +  # Remote syslog config
 +  *.info;daemon.notice;authpriv.* @<log aggregator IP>:514
 +
 +==== Install lshw ====
 +  apt update && apt -y install lshw
 +
 +==== Suppress repeated smartd alerts ====
 +Edit /etc/smartd.conf and add entries such as the following:
 +  /dev/sda -C 197+ -C 198+
 +This will cause smartd to send emails only if the selected parameters increment; otherwise emails get sent every 24 hours as long as the values remain non-zero (which they always will once they aren't).
 ---- ----
 +
 +===== Useful Notes and Tips =====
 CLI command **qm** is your friend.  List/manipulate VMs and such with this utility. CLI command **qm** is your friend.  List/manipulate VMs and such with this utility.
  
-=== Package updates fail after ProxMox install === +==== Enable remote VNC login ability to ProxMox guests ====
-The automatic package update script will fail, because ProxMox “assumes” you will have a subscription (silly ProxMox).  To fix this, the process must run at least once (and fail) and then it can be flipped to the “no-subscription repository” as follows… +
-  Select “Repositories” underneath “Updates” +
-  Disable the ceph-quincy and pve repositories +
-  Click “Add” +
-  In the Repository drop-down box, select “No-Subscription” and click Add. +
- +
-=== Enable remote VNC login ability to ProxMox guests ===+
 Edit the file - **/etc/pve/local/qemu-server/<VMID>.conf** Edit the file - **/etc/pve/local/qemu-server/<VMID>.conf**
  
Line 17: Line 33:
 A VNC connection to the guest is now possible by specifying the **host** IP address and the port chosen ("5977" in the example above). A VNC connection to the guest is now possible by specifying the **host** IP address and the port chosen ("5977" in the example above).
  
-=== Syslog not installed by default === +==== Location of pertinent directories/files ==== 
-To install: +ISOs get stored at **/var/lib/vz/template/iso**
-  apt install -y rsyslog +
-   +
-=== Disable/remove the annoying "no subscription" message that pops during login === +
-<color red>**As of 8.4.5, this no longer works; currently researching alternatives** - https://free-pmx.pages.dev/tools/free-pmx-no-subscription/ might be one.</color>+
  
-Login to the ProxMox node via ssh and run the following code: +===== ZFS Stuff =====
-  sed -Ezi.bak "s/(function\(orig_cmd\) \{)/\1\n\torig_cmd\(\);\n\treturn;/g" /usr/share/javascript/proxmox-widget-toolkit/proxmoxlib.js && systemctl restart pveproxy.service +
-If/when the proxmox-widget-toolkit package gets updated, this command will need to be run again.+
  
 +  zfs get mounted,mountpoint,canmount
 +  zfs list
 +
 +==== Create a multi-disk zfs pool without RAID ====
 +  zpool create -o ashift=12 zpool /dev/sda /dev/sdb
 +https://forum.proxmox.com/threads/task-error-timeout-no-zvol-device-link-for-vm-700-disk-0-found-after-300-sec-found.106242/
 +
 +https://forum.proxmox.com/threads/after-reboot-one-vm-fails-to-start-due-to-task-error-timeout-no-zvol-device-link-for-vm-125-disk-0-found-after-300-sec-found.134434/
 +
 +https://forum.proxmox.com/threads/after-update-and-reboot-vm-will-no-longer-start.165575/
 +
 +===== Proxmox 9 Upgrade =====
 +Things to back up, in addition to the VMs:
 +
 +  - The entire /etc directory (~5MB)
 +  - The /usr/local/sbin directory
 +  
proxmox_notes.1753214293.txt.gz · Last modified: by mike

Donate Powered by PHP Valid HTML5 Valid CSS Driven by DokuWiki